CVE-2026-53721
High
Description
Nuxt is an open-source web development framework for Vue.js. From versions 3.11.0 to before 3.21.7 and 4.0.0 to before 4.4.7, there is a route-rule middleware bypass via case-sensitivity mismatch between vue-router and the routeRules matcher. This issue has been patched in versions 3.21.7 and 4.4.7.
SeverityHigh
CVSS8.2
Exploit probability—
Product
Nuxt
PublishedJun 12, 2026
First seenJun 12, 2026
Weakness typeCWE-178CWE-178CWE-863Incorrect authorization
How to fix
Update
- nuxt nuxt3.21.7, 4.4.7 or later
- nuxt4.4.7, 3.21.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nuxt nuxt | 3.11.0 ≤ v < 3.21.7, 4.0.0 ≤ v < 4.4.7 | 3.21.7, 4.4.7 |
| nuxtnpm | 4.0.0 ≤ v < 4.4.7, 3.11.0 ≤ v < 3.21.7 | 4.4.7, 3.21.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.