CVE-2026-5423

High

Description

@neo4j/graphql library versions prior to 7.5.6 fail to verify the authenticity of a client-supplied, pre-decoded JWT object passed through GraphQL subscription connectionParams. As a result, any unauthenticated remote client that can open a GraphQL-over-WebSocket connection can forge arbitrary JWT claims (e.g. sub, roles) in connectionParams.jwt and have them accepted as authenticated identity for the purposes of @authentication and @subscriptionsAuthorization directive evaluation. This allows a fully unauthenticated attacker to receive subscription events that should be restricted to specific authenticated roles/users. Upgrade the library to versions 7.5.6+ or 5.12.14+. v6 is end-of-life and will not receive a fix.

SeverityHigh
CVSS8.2
Exploit probability—
ProductNeo4j Graphql
PublishedAug 6, 2026
First seenAug 6, 2026
Weakness typeCWE-302CWE-302

How to fix

Update
  • neo4j graphql7.5.6, 5.12.14 or later

Affected products

ProductAffected versionsFixed in
neo4j graphql7.0.0 ≤ v < 7.5.6, 5.0.0 ≤ v < 5.12.14, 6.0.0 ≤ v ≤ 6.6.47.5.6, 5.12.14

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.