CVE-2026-54232

High

Description

vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.1, the vLLM Dockerfile is vulnerable to a dependency confusion attack through the flashinfer-jit-cache package. The package is installed from a custom index (flashinfer.ai/whl/) using --extra-index-url, but the package name was not registered on PyPI, and UV_INDEX_STRATEGY="unsafe-best-match" is set globally. An attacker who registers flashinfer-jit-cache on PyPI with version 0.6.11.post2 can execute arbitrary code as root during the Docker build and backdoor every resulting container image, enabling exfiltration of all user prompts, API credentials, and model data from production vLLM deployments This vulnerability is fixed in 0.22.1.

SeverityHigh
CVSS8.8
Exploit probability—
ProductVllm
PublishedJun 22, 2026
First seenJun 22, 2026
Weakness typeCWE-427CWE-427

How to fix

Update
  • vllm vllm0.22.1 or later
  • vllm0.22.1 or later

Affected products

ProductAffected versionsFixed in
vllm vllmv < 0.22.10.22.1
vllmPyPIv < 0.22.10.22.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.