CVE-2026-54234

High

Description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Prior to 0.24.0, a frontend-legal multi-request speculative decoding workload can cause the rejection sampler to produce a recovered token equal to the model vocabulary size boundary value, which is then converted to negative one when the engine selects the next live token for a request and is written back into the drafter's input ids; that out-of-vocabulary value is later consumed by the model's embedding and attention path and crashes the engine worker with a GPU device-side assertion. The same triggering request sequence is reachable through the public gRPC Generate and Abort endpoints, so a remote client that can send generation requests can crash the shared engine worker, aborting concurrent requests and causing a service-wide denial of service for other clients of the deployment until the worker is restarted. This issue is fixed in version 0.24.0.

SeverityHigh
CVSS7.5
Exploit probability—
ProductVllm
PublishedJul 6, 2026
First seenJul 6, 2026

How to fix

Update
  • vllm vllm0.24.0 or later
  • vllm0.24.0 or later

Affected products

ProductAffected versionsFixed in
vllm vllmv < 0.24.00.24.0
vllmPyPI0.17.1 ≤ v < 0.24.00.24.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.