CVE-2026-54263
Description
Wagtail is an open source content management system built on Django. In versions prior to 7.0.8, 7.3.3 and 7.4.2, reflected cross-site scripting (XSS) vulnerability exists on the dynamic image URL generator view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could craft a URL that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is present for all sites, even if they do not enable the dynamic image serve view. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been fixed in versions 7.0.8, 7.3.3, and 7.4.2.
How to fix
- torchbox wagtail7.3.3, 7.4.2 or later
- wagtail7.3.3, 7.4.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| torchbox wagtail | 7.3 ≤ v < 7.3.3, 7.4 ≤ v < 7.4.2 | 7.3.3, 7.4.2 |
| wagtailPyPI | 7.3 ≤ v < 7.3.3, 7.4 ≤ v < 7.4.2 | 7.3.3, 7.4.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.