CVE-2026-54327
Low
Description
Pi is a minimal terminal coding harness. From 0.74.0 until 0.78.1, Pi stored API keys and OAuth credentials in auth.json. A race condition in the file write path could briefly create or rewrite this file with permissions derived from the process umask before tightening the file to owner-only permissions. This vulnerability is fixed in 0.78.1.
SeverityLow
CVSS2.2
Exploit probability—
Product@mariozechner/pi-coding-agent
PublishedJun 23, 2026
First seenJun 23, 2026
Weakness typeCWE-367CWE-367CWE-732CWE-732
How to fix
Update
- @earendil-works/pi-coding-agent0.78.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| @mariozechner/pi-coding-agentnpm | 0.28.0 ≤ v ≤ 0.73.1 | — |
| @earendil-works/pi-coding-agentnpm | 0.74.0 ≤ v < 0.78.1 | 0.78.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.