CVE-2026-54708
Description
FreePBX is an open source IP PBX. Prior to versions 16.0.72 and 17.0.7, a critical vulnerability exists in the FreePBX backup Module that allows authenticated attackers to execute arbitrary code on the server. Authentication with a known username that has sufficient access permissions and/or write access to backup files is required. This vulnerability is caused by improper path sanitization in the backup restore functionality, enabling attackers to upload malicious PHP files to the web root directory. This issue has been patched in versions 16.0.72 and 17.0.7.
How to fix
- sangoma freepbx16.0.72, 17.0.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| sangoma freepbx | 16.0 ≤ v < 16.0.72, 17.0 ≤ v < 17.0.7 | 16.0.72, 17.0.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.