CVE-2026-55182

High

Description

LibreNMS is a network monitoring system. In versions from 21.6.0 up to 26.5.0, the Signal alert transport is vulnerable to command injection because the signal-cli path and the Recipient field of an alert transport entry are insufficiently escaped before being passed to an exec call. An authenticated administrator can craft a transport entry whose Recipient contains shell metacharacters and whose path points to the bundled composer_wrapper.php script, which itself passes attacker-controlled input to further unsafe exec calls. By chaining these calls, the administrator can execute arbitrary operating-system commands on the LibreNMS host. This issue is fixed in version 26.5.0.

SeverityHigh
CVSS8.6
Exploit probability—
ProductLibrenms/librenms
PublishedAug 26, 2026
First seenAug 26, 2026

How to fix

Update
  • librenms/librenms26.5.0 or later

Affected products

ProductAffected versionsFixed in
librenms/librenmsPackagist21.6.0 ≤ v < 26.5.026.5.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.