CVE-2026-55514

Medium

Description

vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.

SeverityMedium
CVSS6.5
Exploit probability—
ProductVllm
PublishedJul 6, 2026
First seenJul 6, 2026
Weakness typeCWE-617CWE-617

How to fix

Update
  • vllm vllm0.24.0 or later
  • vllm0.24.0 or later

Affected products

ProductAffected versionsFixed in
vllm vllm0.12.0 ≤ v < 0.24.00.24.0
vllmPyPI0.12.0 ≤ v < 0.24.00.24.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.