CVE-2026-55547
Description
Yamcs is a mission control framework. Prior to 5.12.8 and 5.13.2, Yamcs omits SystemPrivilege.ControlAccess checks from IamApi.listRoles, IamApi.getRole, and IamApi.listPrivileges in yamcs-core/src/main/java/org/yamcs/http/api/IamApi.java. Any authenticated account can call GET /api/roles, GET /api/roles/{name}, and GET /api/privileges to enumerate available system privileges and configured role mappings. The disclosure reveals security configuration that can support targeted privilege-escalation attempts. This issue is fixed in versions 5.12.8 and 5.13.2.
How to fix
- org.yamcs:yamcs-core5.13.2, 5.12.8 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| org.yamcs:yamcs-coreMaven | 5.13.0 ≤ v < 5.13.2, v < 5.12.8 | 5.13.2, 5.12.8 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.