CVE-2026-55778
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.9.1-alpha.11 and 8.6.81, the default fileUpload.fileExtensions blocklist could be bypassed by uploading a file with a non-standard or compound extension and dangerous content type, allowing storage adapters such as S3 and GCS to serve attacker-supplied active content and enable stored cross-site scripting. This issue is fixed in versions 9.9.1-alpha.11 and 8.6.81.
How to fix
- parse-server9.9.1-alpha.11, 8.6.81 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parse-servernpm | 9.0.0 ≤ v < 9.9.1-alpha.11, v < 8.6.81 | 9.9.1-alpha.11, 8.6.81 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.