CVE-2026-56091

High

Description

When using Apache Shiro with the shiro-guice module in a web servlet context, a specially crafted HTTP request may cause an authentication bypass. This vulnerability is similar to https://www.cve.org/CVERecord?id=CVE-2020-1957 https://www.cve.org/CVERecord , except that it affects the `shiro-guice` module instead of the `shiro-spring` module. This issue affects all Apache Shiro versions through 2.x, and 3.0.0-alpha-1 only when using `shiro-guice` module in a web servlet context. Upgrade to version 3.0.0 or later, which fixes the issue.

SeverityHigh
CVSS8.2
Exploit probability—
ProductOrg.apache.shiro:shiro-guice
PublishedJun 25, 2026
First seenJun 25, 2026
Weakness typeCWE-289CWE-289

How to fix

Update
  • org.apache.shiro:shiro-guice3.0.0 or later

Affected products

ProductAffected versionsFixed in
org.apache.shiro:shiro-guiceMaven2.0.0 ≤ v < 3.0.03.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.