CVE-2026-56356
Description
n8n contains a stored cross-site scripting vulnerability in the Chat Trigger node's Custom CSS field due to a misconfiguration of the sanitize-html library. Affected releases are those before 1.123.27, the 2.0.0 through 2.13.2 line, and 2.14.0 (fixed in 1.123.27, 2.13.3, and 2.14.1). An authenticated user with permission to create or modify workflows can inject JavaScript that bypasses sanitization, resulting in stored XSS against any user who visits the public chat page.
How to fix
- n8n n8n1.123.27, 2.13.3 or later
- n8n1.123.27, 2.14.1, 2.13.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| n8n n8n | v < 1.123.27, 2.0.0 ≤ v < 2.13.3, 2.14.0 | 1.123.27, 2.13.3 |
| n8nnpm | v < 1.123.27, 2.14.0 ≤ v < 2.14.1, 2.0.0-rc.0 ≤ v < 2.13.3 | 1.123.27, 2.14.1, 2.13.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.