CVE-2026-56383
Description
Craft CMS contains a stored cross-site scripting (XSS) vulnerability in the editableTable.twig component when using the 'Row Heading' column type. The application fails to sanitize input within row heading default values, allowing an attacker with an administrator account (with allowAdminChanges enabled) to inject arbitrary JavaScript that executes when another user views a page containing the affected table field. Affected versions are >= 4.5.0-beta.1 through 4.16.18 and >= 5.0.0-RC1 through 5.8.22; fixed in 4.16.19 and 5.8.23.
How to fix
- craftcms/cms4.16.19, 5.8.23 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| craftcms/cmsPackagist | 4.5.0-beta.1 ≤ v < 4.16.19, 5.0.0-RC1 ≤ v < 5.8.23 | 4.16.19, 5.8.23 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.