CVE-2026-57216
Description
RabbitMQ is a messaging and streaming broker. Prior to 3.13.15, 4.0.20, 4.1.11, and 4.2.6, AMQP 0-9-1, AMQP 1.0, and Stream Protocol authentication can allow a loopback-restricted user such as guest to connect remotely when traffic is accepted through a trusted PROXY-protocol path and the backend listener is loopback-bound because the loopback check uses the listener-side socket address instead of the real client source. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.
How to fix
- broadcom rabbitmq_server3.13.15, 4.0.20, 4.1.11, 4.2.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| broadcom rabbitmq_server | 3.13.0 ≤ v < 3.13.15, 4.0.0 ≤ v < 4.0.20, 4.1.0 ≤ v < 4.1.11, 4.2.0 ≤ v < 4.2.6 | 3.13.15, 4.0.20, 4.1.11, 4.2.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.