CVE-2026-57480
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.9.1-alpha.12 and 8.6.82, deeply nested $or, $and, and $nor query condition operators in the REST API or LiveQuery query handling could trigger exponential-time processing in the internal query-traversal helper and block the Node.js event loop. This issue is fixed in versions 9.9.1-alpha.12 and 8.6.82.
How to fix
- parse-server9.9.1-alpha.12, 8.6.82 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parse-servernpm | 9.0.0 ≤ v < 9.9.1-alpha.12, v < 8.6.82 | 9.9.1-alpha.12, 8.6.82 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.