CVE-2026-57817
Description
The OpenID Connect Core 1.0 specification mandates that the RP MUST validate the `c_hash` parameter when operating in the Hybrid Flow. If an Apache CXF RP is integrated with a non-compliant or misconfigured Identity Provider (IdP) that omits the `c_hash`, the RP becomes vulnerable to Authorization Code Substitution/Injection attacks. Users are recommended to upgrade to versions 4.2.3 or 4.1.8 or 3.6.12, which fix this issue.
How to fix
- apache cxf3.6.12, 4.1.8, 4.2.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache cxf | v < 3.6.12, 4.0.0 ≤ v < 4.1.8, 4.2.0 ≤ v < 4.2.3 | 3.6.12, 4.1.8, 4.2.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.