CVE-2026-57915

High

Description

It is possible to bypass the Kerberos pre-authentication check in Apache Kerby by sending a PA-DATA with an unrecognized or unsupported type. Users are recommended to upgrade to version 2.1.2, which fixes this issue.

SeverityHigh
CVSS7.3
Exploit probability—
ProductOrg.apache.kerby:kerb-server
PublishedJun 26, 2026
First seenJun 26, 2026
Weakness typeCWE-304CWE-304

How to fix

Update
  • org.apache.kerby:kerb-server2.1.2 or later

Affected products

ProductAffected versionsFixed in
org.apache.kerby:kerb-serverMavenv < 2.1.22.1.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.