CVE-2026-57967

Critical

Description

An unauthenticated remote attacker can craft a CORE protocol SESSION_REATTACH packet to steal an existing session and assume ongoing execution of the previously authenticated session. This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0. Users are recommended to upgrade to version 2.57.0, which fixes the issue.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Artemis
PublishedSep 10, 2026
First seenSep 10, 2026

How to fix

Update
  • apache artemis2.44.0, 2.57.0 or later

Affected products

ProductAffected versionsFixed in
apache artemis1.0.0 ≤ v < 2.44.0, 2.50.0 ≤ v < 2.57.02.44.0, 2.57.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.