CVE-2026-58159

High

Description

Apache Traffic Server can bypass IP access controls on UDS listeners and through ACL matching errors. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

SeverityHigh
CVSS8.2
Exploit probability—
ProductApache Traffic Server
PublishedJul 29, 2026
First seenJul 29, 2026

How to fix

Update
  • apache traffic_server9.2.15, 10.1.4 or later

Affected products

ProductAffected versionsFixed in
apache traffic_server8.0.0 ≤ v ≤ 8.1.9, 9.0.0 ≤ v < 9.2.15, 10.0.0 ≤ v < 10.1.49.2.15, 10.1.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.