CVE-2026-5842

High

Description

A security vulnerability has been detected in decolua 9router up to 0.3.47. The impacted element is an unknown function of the file /api of the component Administrative API Endpoint. The manipulation leads to authorization bypass. The attack is possible to be carried out remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 0.3.75 is sufficient to resolve this issue. It is suggested to upgrade the affected component.

SeverityHigh
CVSS7.3
Exploit probability—
Product9router
PublishedApr 9, 2026
First seenApr 9, 2026

How to fix

Update
  • 9router0.3.75 or later

Affected products

ProductAffected versionsFixed in
9routernpmv < 0.3.750.3.75

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.