CVE-2026-59084

Critical

Description

Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.13 through 9.0.119, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.24, 10.1.57 or 9.0.120 which fix the issue.

SeverityCritical
CVSS9.1
Exploit probability—
ProductApache Tomcat
PublishedJul 14, 2026
First seenJul 14, 2026
Weakness typeCWE-1059CWE-1059

How to fix

Affected products

ProductAffected versionsFixed in
apache tomcat7.0.100 ≤ v ≤ 7.0.109, 8.5.38 ≤ v ≤ 8.5.100, 9.0.13 ≤ v ≤ 9.0.119, 10.1.0 ≤ v ≤ 10.1.56, 11.0.0 ≤ v ≤ 11.0.23—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-59084 · Apache Tomcat · Dark Radar