CVE-2026-59085
Critical
Description
Server-Side Request Forgery (SSRF) vulnerability in Apache CloudStack's webhook module, exploitable via webhook delivery requests. This issue affects Apache CloudStack: from 4.20.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.
SeverityCritical
CVSS9.1
Exploit probability—
Product
Apache Cloudstack
PublishedAug 21, 2026
First seenAug 21, 2026
Weakness typeCWE-918Server-side request forgery (SSRF)
How to fix
Update
- apache cloudstack4.20.3.1, 4.22.1.1 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache cloudstack | 4.20.0.0 ≤ v < 4.20.3.1, 4.21.0.0 ≤ v < 4.22.1.1 | 4.20.3.1, 4.22.1.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.