CVE-2026-59195
Description
pnpm is a package manager. Prior to 10.34.4 and 11.8.0, pnpm accepts package names from the env lockfile configDependencies section and uses those names directly when creating config dependency symlinks under node_modules/.pnpm-config. A malicious repository can commit a crafted pnpm-lock.yaml whose env-lockfile document contains a traversal-shaped config dependency name. During pnpm install, pnpm installs the config dependency and creates a symlink at a path derived from that name. This vulnerability is fixed in 10.34.4 and 11.8.0.
How to fix
- pnpm pnpm10.34.4, 11.8.0 or later
- pnpm10.34.4, 11.8.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| pnpm pnpm | v < 10.34.4, 11.0.0 ≤ v < 11.8.0 | 10.34.4, 11.8.0 |
| pnpmnpm | v < 10.34.4, 11.0.0 ≤ v < 11.8.0 | 10.34.4, 11.8.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.