CVE-2026-59821

High

Description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.82.0-stable, LiteLLM's Custom Code Guardrails production create and update paths did not apply the same sandboxing and validation used by the test endpoint, allowing a privileged user with access to create or update guardrails to submit custom Python code that executed in the LiteLLM proxy environment and could expose secrets available to the process. This issue is fixed in version 1.82.0-stable.

SeverityHigh
CVSS7.2
Exploit probability—
ProductLitellm
PublishedJul 8, 2026
First seenJul 8, 2026

How to fix

Update
  • litellm litellm1.82.0 or later
  • litellm1.82.0 or later

Affected products

ProductAffected versionsFixed in
litellm litellmv < 1.82.0, 1.82.01.82.0
litellmPyPIv < 1.82.01.82.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.