CVE-2026-59878
Description
Improper Input Validation vulnerability in Apache ActiveMQ AMQP, Apache ActiveMQ, Apache ActiveMQ All. A remote unauthenticated peer that can reach an exposed AMQP NIO connector can trigger denial-of-service behavior by sending a frame size value. This cause the NIO threads to die and if done rapidly enough can lead to exhaustion of the NIO thread pool denying service to other connections. This issue affects Apache ActiveMQ AMQP: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8. Users are recommended to upgrade to version 5.19.9, 6.2.8, or 6.3.0 which fixes the issue.
How to fix
- apache activemq5.19.9, 6.2.8 or later
- apache activemq_all5.19.9, 6.2.8 or later
- apache activemq_amqp5.19.9, 6.2.8 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache activemq | v < 5.19.9, 6.0.0 ≤ v < 6.2.8 | 5.19.9, 6.2.8 |
| apache activemq_all | v < 5.19.9, 6.0.0 ≤ v < 6.2.8 | 5.19.9, 6.2.8 |
| apache activemq_amqp | v < 5.19.9, 6.0.0 ≤ v < 6.2.8 | 5.19.9, 6.2.8 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.