CVE-2026-59932

High

Description

PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. In versions 4.0.0 through 5.8.0, 3.3.0 through 3.10.6, 2.2.0 through 2.4.6, 2.0.0 through 2.1.17, and all releases up to and including 1.30.5, the Gnumeric reader reads attacker-supplied .gnumeric files into memory and, when the file starts with gzip magic bytes, calls gzdecode() on the full compressed contents without enforcing a decompressed-size limit. A very small compressed .gnumeric file can expand to data larger than the PHP memory limit and crash the process during Gnumeric::canRead() before the file is rejected or fully parsed. This is reachable through normal file-type detection and Gnumeric loading paths, so applications that accept attacker-controlled spreadsheet uploads can suffer denial of service. This issue has been fixed in versions 5.8.1, 3.10.7, 2.4.7, 2.1.18 and 1.30.6.

SeverityHigh
CVSS7.5
Exploit probability—
ProductPhpoffice/phpspreadsheet
PublishedJul 28, 2026
First seenJul 28, 2026

How to fix

Update
  • phpoffice/phpspreadsheet5.8.1, 3.10.7, 2.4.7, 2.1.18, 1.30.6 or later

Affected products

ProductAffected versionsFixed in
phpoffice/phpspreadsheetPackagist4.0.0 ≤ v < 5.8.1, 3.3.0 ≤ v < 3.10.7, 2.2.0 ≤ v < 2.4.7, 2.0.0 ≤ v < 2.1.18, v < 1.30.65.8.1, 3.10.7, 2.4.7, 2.1.18, 1.30.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.