CVE-2026-59946
Description
Composer is a dependency Manager for the PHP language. Prior to 2.2.29 and 2.10.2, a Composer package bin entry containing .. path segments can resolve outside the package install directory and cause Composer's binary installation flow to chmod an existing host file to a world-readable and world-executable mode during composer install, update, or require. This issue is fixed in versions 2.2.29 and 2.10.2.
How to fix
- composer/composer2.10.2, 2.2.29 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| composer/composerPackagist | 2.3.0 ≤ v < 2.10.2, 1.0.0 ≤ v < 2.2.29 | 2.10.2, 2.2.29 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.