CVE-2026-59948

High

Description

Composer is a dependency Manager for the PHP language. Prior to 2.2.29 and 2.10.2, a maliciously crafted package from an untrusted repository other than Packagist.org or Private Packagist can cause Composer to write attacker-controlled files outside the vendor directory and outside the project during install or update by using an invalid package name that is not correctly validated before dependency-resolution results are written or installed. This issue is fixed in versions 2.2.29 and 2.10.2.

SeverityHigh
CVSS7.0
Exploit probability—
ProductComposer/composer
PublishedJul 8, 2026
First seenJul 8, 2026

How to fix

Update
  • composer/composer2.10.2, 2.2.29 or later

Affected products

ProductAffected versionsFixed in
composer/composerPackagist2.3.0 ≤ v < 2.10.2, 1.0.0 ≤ v < 2.2.292.10.2, 2.2.29

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.