CVE-2026-60080
High
Description
Use After Free vulnerability in the Rust deserialization logic of Apache Fory. This issue affects Apache Fory from 0.13.0 through 1.3.0. A crafted Fory payload could cause undefined behavior, process crash, or potential memory disclosure. Users are recommended to upgrade to version 1.4.0, which fixes the issue.
SeverityHigh
CVSS7.3
Exploit probability—
Product
Apache Fory
PublishedJul 21, 2026
First seenJul 21, 2026
Weakness typeCWE-416Use after free
How to fix
Update
- apache fory1.4.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache fory | 0.13.0 ≤ v < 1.4.0 | 1.4.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.