CVE-2026-61399

Medium

Description

Improper Encoding or Escaping of Output vulnerability in Apache CloudStack's UI while using Lock User Functionality. This issue affects Apache CloudStack: from 4.20.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

SeverityMedium
CVSS4.8
Exploit probability—
ProductApache Cloudstack
PublishedAug 21, 2026
First seenAug 21, 2026
Weakness typeCWE-116CWE-116

How to fix

Update
  • apache cloudstack4.20.3.1, 4.22.1.1 or later

Affected products

ProductAffected versionsFixed in
apache cloudstack4.20.0.0 ≤ v < 4.20.3.1, 4.21.0.0 ≤ v < 4.22.1.14.20.3.1, 4.22.1.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.