CVE-2026-61487
Description
Improper Authorization vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ. An authenticated low-privilege user can bypass a per-destination write ACL by sending to an ActiveMQ temporary composite destination whose physical name is a comma-separated composite of real queues. This allows publishing messages to any of the destinations in the list without proper write ACL permissions because the authorization check is bypassed due to the composite destination being marked as temporary. This issue affects Apache ActiveMQ Broker: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8. Users are recommended to upgrade to version 5.19.9, 6.2.8 or 6.3.0, which fixes the issue.
How to fix
- apache activemq5.19.9, 6.2.8 or later
- apache activemq_all5.19.9, 6.2.8 or later
- apache activemq_broker5.19.9, 6.2.8 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache activemq | v < 5.19.9, 6.0.0 ≤ v < 6.2.8 | 5.19.9, 6.2.8 |
| apache activemq_all | v < 5.19.9, 6.0.0 ≤ v < 6.2.8 | 5.19.9, 6.2.8 |
| apache activemq_broker | v < 5.19.9, 6.0.0 ≤ v < 6.2.8 | 5.19.9, 6.2.8 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.