CVE-2026-62183

Critical

Description

Improper Privilege Management vulnerability in Apache Syncope. When: * the all-Java user workflow adapter is configured, or * the Flowable user workflow adapter is configured, bearing a BPMN definition not requiring admin approval for user self registration of self update requests the following scenario could happen. A REST API call can allow the user to grant themselves one or more of defined Roles, thus gaining their Entitlements and becoming in fact an administrator; the actual Entitlements gained depend on the Roles that are effectively defined on the specific Syncope deployment. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1. Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Syncope
PublishedJul 20, 2026
First seenJul 20, 2026

How to fix

Update
  • apache syncope4.0.7, 4.1.2 or later

Affected products

ProductAffected versionsFixed in
apache syncope3.0.0 ≤ v ≤ 3.0.16, 4.0.0 ≤ v < 4.0.7, 4.1.0 ≤ v < 4.1.24.0.7, 4.1.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.