CVE-2026-62231

High

Description

The Grav API plugin (getgrav/grav-plugin-api) before 1.0.6 contains an authorization bypass: API keys can be created with a restricted scopes array, but the ApiKeyAuthenticator class never reads or enforces these scopes. It loads and returns the owning user's full account object, so a key created with limited scopes (e.g. read-only) can perform any write, delete, or administrative operation the owning user is authorized for. Fixed in 1.0.6.

SeverityHigh
CVSS8.1
Exploit probability—
ProductGrav
PublishedJul 17, 2026
First seenJul 17, 2026

How to fix

Update
  • getgrav grav1.0.6 or later

Affected products

ProductAffected versionsFixed in
getgrav gravv < 1.0.61.0.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.