CVE-2026-62295

High

Description

HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java. Prior to 6.9.11, the JSON utility parser in org.hl7.fhir.utilities.json.parser.JsonParser enforces no maximum nesting depth for arrays or objects. As a result, a small but deeply nested, syntactically valid FHIR JSON document can trigger unbounded readArray() or readObject() recursion, raising a StackOverflowError before structural validation runs. An attacker who can submit JSON resources for validation can thus crash the request thread, and services that do not isolate StackOverflowError safely may experience worker loss or process instability — a denial-of-service condition. This issue is fixed in version 6.9.11.

SeverityHigh
CVSS7.5
Exploit probability42. percentile0.5%
ProductHapifhir Org.hl7.fhir.core
PublishedAug 7, 2026
First seenAug 7, 2026

How to fix

Sources list no fixed version or patch link for this vulnerability.

Affected products

ProductAffected versionsFixed in
hapifhir org.hl7.fhir.core< 6.9.11—
hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.r5< 6.9.11—
hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.utilities< 6.9.11—
hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.validation< 6.9.11—
hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli< 6.9.11—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.