CVE-2026-62391
High
Description
The security fix for CVE-2025-66518 is incomplete. Any client who can access to Apache Kyuubi Server via Kyuubi frontend protocols can bypass server-side config kyuubi.session.local.dir.allowlist via unprefixed Spark config aliases. This issue affects Apache Kyuubi: from 1.6.0 before 1.12.0. Users are recommended to upgrade to version 1.12.0, which fixes the issue.
SeverityHigh
CVSS8.1
Exploit probability56. percentile0.8%
Product
Apache Kyuubi
PublishedJul 31, 2026
First seenJul 31, 2026
Weakness typeCWE-22Path traversalCWE-27CWE-27
How to fix
Update
- apache kyuubi1.12.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache kyuubi | 1.6.0 ≤ v < 1.12.0 | 1.12.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.