CVE-2026-62392

Critical

Description

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Kylin. A backend API may bring job config parameters to OS command line. This issue affects Apache Kylin: from 4 through 5.0.3. Users are recommended to upgrade to version 5.0.4, which fixes the issue.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Kylin
PublishedJul 14, 2026
First seenJul 14, 2026

How to fix

Update
  • apache kylin5.0.4 or later

Affected products

ProductAffected versionsFixed in
apache kylin4.0.0 ≤ v < 5.0.45.0.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.