CVE-2026-63043
High
Description
Relative Path Traversal vulnerability in Apache InLong. Arbitrary file read from the Agent host filesystem. This issue affects Apache InLong: from 2.0.0 before 2.4.0. Users are advised to upgrade to Apache InLong's 2.4.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/12146 .
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Inlong
PublishedAug 20, 2026
First seenAug 20, 2026
Weakness typeCWE-23CWE-23
How to fix
Update
- apache inlong2.4.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache inlong | 2.0.0 ≤ v < 2.4.0 | 2.4.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.