CVE-2026-64606
Critical
Description
Deserialization of untrusted data vulnerability that may allow class-registration checks to be bypassed during Java lambda deserialization. Only lambda capture class is affected This issue affects Apache Fory: from before 1.4.0. Users are recommended to upgrade to version 1.4.0, which fixes the issue.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Apache Fory
PublishedJul 21, 2026
First seenJul 21, 2026
Weakness typeCWE-502Deserialization of untrusted data
How to fix
Update
- apache fory1.4.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache fory | 0.5.0 ≤ v < 1.4.0 | 1.4.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.