CVE-2026-64642
High
Description
Next.js is a React framework for building full-stack web applications. In versions 16.0.0 through 16.2.10, crafted requests targeting Next.js applications using App Router built with Turbopack and a single entry in config.i18n.locales can bypass middleware/proxy based authentication. This issue has been fixed in version 16.2.11.
SeverityHigh
CVSS8.3
Exploit probability51. percentile0.6%
Product
Vercel Next.js
PublishedJul 27, 2026
First seenJul 27, 2026
Weakness typeCWE-285CWE-285
How to fix
Update
- vercel next.js16.2.11 or later
- next16.2.11 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vercel next.js | 16.0.0 ≤ v < 16.2.11 | 16.2.11 |
| nextnpm | 16.0.0 ≤ v < 16.2.11 | 16.2.11 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.