CVE-2026-64958
High
Description
An incomplete fix for CVE-2026-50645 means that it is still possible to perform a denial of service attack on Apache CXF by sending a message with many attachment headers. Users are recommended to upgrade to versions 4.2.3 or 4.1.8 or 3.6.12, which fix this issue.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Cxf
PublishedAug 6, 2026
First seenAug 6, 2026
Weakness typeCWE-400Uncontrolled resource consumption
How to fix
Update
- apache cxf3.6.12, 4.1.8, 4.2.3 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache cxf | v < 3.6.12, 4.0.0 ≤ v < 4.1.8, 4.2.0 ≤ v < 4.2.3 | 3.6.12, 4.1.8, 4.2.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.