CVE-2026-6550
Description
Cryptographic algorithm downgrade in the caching layer of Amazon AWS Encryption SDK for Python before version 3.3.1 and before version 4.0.5 might allow an authenticated local threat actor to bypass key commitment policy enforcement via a shared key cache, resulting in ciphertext that can be decrypted to multiple different plaintexts. To remediate this issue, users should upgrade to version 3.3.1, 4.0.5 or above.
How to fix
- aws-encryption-sdk3.3.1, 4.0.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| aws-encryption-sdkPyPI | 2.0.0 ≤ v < 3.3.1, 4.0.0 ≤ v < 4.0.5 | 3.3.1, 4.0.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.