CVE-2026-65637

Critical

Description

Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990. This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

SeverityCritical
CVSS9.8
Exploit probability55. percentile0.8%
ProductApache Tomcat
PublishedAug 25, 2026
First seenAug 25, 2026

How to fix

Update
  • apache tomcat9.0.121, 10.1.58, 11.0.25 or later
  • org.apache.tomcat:tomcat-coyote11.0.25, 10.1.59, 9.0.121 or later
  • org.apache.tomcat.embed:tomcat-embed-core11.0.25, 10.1.59, 9.0.121 or later

Affected products

ProductAffected versionsFixed in
apache tomcat9.0.115 ≤ v < 9.0.121, 10.1.53 ≤ v < 10.1.58, 11.0.20 ≤ v < 11.0.259.0.121, 10.1.58, 11.0.25
org.apache.tomcat:tomcat-coyoteMaven11.0.20 ≤ v < 11.0.25, 10.1.53 ≤ v < 10.1.59, 9.0.115 ≤ v < 9.0.12111.0.25, 10.1.59, 9.0.121
org.apache.tomcat.embed:tomcat-embed-coreMaven11.0.20 ≤ v < 11.0.25, 10.1.53 ≤ v < 10.1.59, 9.0.115 ≤ v < 9.0.12111.0.25, 10.1.59, 9.0.121

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-65637 · Apache Tomcat · Dark Radar