CVE-2026-65905
Description
Authentication Bypass by Capture-replay vulnerability in Apache Tomcat's DIGEST authenticator. If, before windowSize requests have been made, a client makes a DIGEST authenticated request with a nonceCount on the upper boundary of the replay window then that request is replayable once only while the associated nonceCount remains within the replay window. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.30 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.
How to fix
- apache tomcat9.0.121, 10.1.58, 11.0.25 or later
- org.apache.tomcat:tomcat11.0.25, 10.1.58, 9.0.121 or later
- org.apache.tomcat.embed:tomcat-embed-core11.0.25, 10.1.58, 9.0.121 or later
- org.apache.tomcat:tomcat-catalina11.0.25, 10.1.58, 9.0.121 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tomcat | 7.0.30 ≤ v ≤ 7.0.109, 8.5.0 ≤ v < 9.0.121, 10.1.0 ≤ v < 10.1.58, 11.0.0 ≤ v < 11.0.25 | 9.0.121, 10.1.58, 11.0.25 |
| org.apache.tomcat:tomcatMaven | 11.0.0-M1 ≤ v < 11.0.25, 10.1.0-M1 ≤ v < 10.1.58, 9.0.0.M1 ≤ v < 9.0.121, 8.5.0 ≤ v ≤ 8.5.100, 7.0.30 ≤ v ≤ 7.0.109 | 11.0.25, 10.1.58, 9.0.121 |
| org.apache.tomcat.embed:tomcat-embed-coreMaven | 11.0.0-M1 ≤ v < 11.0.25, 10.1.0-M1 ≤ v < 10.1.58, 9.0.0.M1 ≤ v < 9.0.121, 8.5.0 ≤ v ≤ 8.5.100, 7.0.30 ≤ v ≤ 7.0.109 | 11.0.25, 10.1.58, 9.0.121 |
| org.apache.tomcat:tomcat-catalinaMaven | 11.0.0-M1 ≤ v < 11.0.25, 10.1.0-M1 ≤ v < 10.1.58, 9.0.0.M1 ≤ v < 9.0.121, 8.5.0 ≤ v ≤ 8.5.100, 7.0.30 ≤ v ≤ 7.0.109 | 11.0.25, 10.1.58, 9.0.121 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.