CVE-2026-66142

High

Description

Apache Neethi is vulnerable to uncontrolled recursion when parsing policies that lack policy Ids or with deeply nested structures, which may lead to a denial of service attack when parsing policies due to runtime memory exhaustion. Users are recommended to upgrade to version 3.2.3, which fixes this issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Neethi
PublishedJul 24, 2026
First seenJul 24, 2026

How to fix

Update
  • apache neethi3.2.3 or later

Affected products

ProductAffected versionsFixed in
apache neethiv < 3.2.33.2.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.