CVE-2026-6637

High

Description

Stack buffer overflow in PostgreSQL module "refint" allows an unprivileged database user to execute arbitrary code as the operating system user running the database. A distinct attack is possible if the application declares a user-controlled column as a "refint" cascade primary key and facilitates user-controlled updates to that column. In that case, a SQL injection allows a primary key update value provider to execute arbitrary SQL as the database user performing the primary key update. Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.

SeverityHigh
CVSS8.8
Exploit probability—
ProductPostgresql
PublishedMay 14, 2026
First seenMay 14, 2026

How to fix

Update
  • postgresql postgresql14.23, 15.18, 16.14, 17.10, 18.4 or later

Affected products

ProductAffected versionsFixed in
postgresql postgresqlv < 14.23, 15.0 ≤ v < 15.18, 16.0 ≤ v < 16.14, 17.0 ≤ v < 17.10, 18.0 ≤ v < 18.414.23, 15.18, 16.14, 17.10, 18.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.