CVE-2026-67222
Description
RabbitMQ is a messaging and streaming broker. From 3.13.0 until 3.13.15, 4.0.20, 4.1.11, and 4.2.6, mechanisms/1 applied list_to_atom/1 to every colon-delimited token in an attacker-controlled auth_mechanism value, permanently consuming Erlang VM atoms and allowing the node to be crashed with a large request. Exploitation requires the Shovel or Federation plugin to be in use, and setting auth_mechanism requires the policymaker tag. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.
How to fix
- broadcom rabbitmq_server3.13.15, 4.0.20, 4.1.11, 4.2.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| broadcom rabbitmq_server | 3.13.0 ≤ v < 3.13.15, 4.0.0 ≤ v < 4.0.20, 4.1.0 ≤ v < 4.1.11, 4.2.0 ≤ v < 4.2.6 | 3.13.15, 4.0.20, 4.1.11, 4.2.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.