CVE-2026-67413
Description
RabbitMQ is a messaging and streaming broker. From 4.0.0 until 4.0.23, 4.1.14, 4.2.9, and 4.3.3, the optional rabbitmq_jms_topic_exchange plugin's x-jms-topic exchange accepted a client-controlled rjms_erlang_selector binding expression whose LIKE evaluator expanded percent and underscore wildcards into overlapping PCRE fragments. It executed those fragments with raw re:run/3 without match or recursion limits, allowing an authenticated tenant that can bind and publish to consume broker scheduler CPU and deny service with pathological selectors. This issue is fixed in versions 4.0.23, 4.1.14, 4.2.9, and 4.3.3.
How to fix
- broadcom rabbitmq_server4.0.23, 4.1.14, 4.2.9, 4.3.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| broadcom rabbitmq_server | 4.0.0 ≤ v < 4.0.23, 4.1.0 ≤ v < 4.1.14, 4.2.0 ≤ v < 4.2.9, 4.3.0 ≤ v < 4.3.3 | 4.0.23, 4.1.14, 4.2.9, 4.3.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.