CVE-2026-67434

High

Description

PHP_CodeSniffer tokenizes PHP files and detects violations of a defined set of coding standards. Prior to versions 3.13.6 and 4.0.2, PHP_CodeSniffer contains a command injection vulnerability in the code that generates the Gitblame, Hgblame, and Svnblame report formats. As a result, running PHP_CodeSniffer over untrusted files, for example in a continuous integration pipeline that scans pull requests, or on a developer machine reviewing third party code, could result in attacker controlled shell commands being executed when the Gitblame, Hgblame, or Svnblame report processes a file whose name contains shell metacharacters. Users using the default Full report, or any of the other non-blame reports, are not affected. Users on a runtime platform which does not allow filenames to contain shell metacharacters, such as " and ;, are not affected. This issue is fixed in versions 3.13.6 and 4.0.2.

SeverityHigh
CVSS7.3
Exploit probability—
ProductSquizlabs/php Codesniffer
PublishedAug 6, 2026
First seenAug 6, 2026

How to fix

Update
  • squizlabs/php_codesniffer3.13.6, 4.0.2 or later

Affected products

ProductAffected versionsFixed in
squizlabs/php_codesnifferPackagistv < 3.13.6, 4.0.0 ≤ v < 4.0.23.13.6, 4.0.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.