CVE-2026-67589

High

Description

A pre-authentication attacker could leverage type size/count handling to cause excessive allocation leading to potential denial of service. This issue affects Apache Qpid ProtonJ2: through 1.1.0. Users are recommended to upgrade to version 1.2.0, which fixes the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Qpid
PublishedAug 5, 2026
First seenAug 5, 2026
Weakness typeCWE-789CWE-789

How to fix

Update
  • apache qpid_protonj21.2.0 or later

Affected products

ProductAffected versionsFixed in
apache qpid_protonj2v < 1.2.01.2.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.